Start a new topic

CrewBuddy not working correctly

Last couple of days CrewBuddy has not worked correctly. I am unable to see Gate assignments, delays, etc. I know a few others are havung same problem. Do we need to do anything to fix this or are you working on the fix? Thanks. I love CrewBuddy and need it to work.

Hi Paulette,

I really apologize that it's not working. SWA changed the flight status data structure Friday morning and it killed CrewBuddy's ability to get the gates. I coded a fix and submitted the update to Apple. We were approved for an expedited review, so I'm anticipating that the update should be available today or tomorrow.

Thanks for your patience!

Good news!  

The update is available for download from the App Store now!  It's version 1.4.2

My app is running extremely slow with a delay everytime i click anything

Hi Anitra,

I sent you a message, but it looks like you're using an old version of CrewBuddy.  Let me know what happens after you update.


There is an error message on the landing gate display on all the legs. It shows 0... With something about arrival overflow in small print.

Hi Scott.

SWA changed the data structure of the flight status again.  It's causing the problem you're talking about.  I'm almost done writing the code to fix it.  I'll be submitting it to Apple for approval soon.  Apple usually takes several days to finish their approval.  

Thanks for your patience!  I'm working on it as fast as I can.


Update is now available for download!

I just purchased the annual membership and now it will not let me open the app. Just crashes. I had the one month trial and it worked fine. Please let me know what I can do to trouble shoot? Or is there a problem with the app that is currently trying to be fixed?

Hi Crystal,

I sent you an email.


How long more will this problem take to get fixed, very annoying
When will this current problem be fixed?

When they upgraded CWA it prohibited flight attendants from being able to sync CrewBuddy.  I've been hard at work for the last few days coding a fix to accommodate the CWA changes.

I've completed the fix and we're waiting for Apple to approve it.

I still cannot get in it says can not sync then say has stop to protect trips. Is there anything being done fix this problem ?

Hi Victor,

I'm not sure if you saw the prior post I made.  There's a lot being done to fix this problem.

I've finished developing the fix.  It was a complicated fix, so I apologize that it took a few days to develop it.  I submitted the fix to Apple for approval yesterday and requested an expedited review.  

Apple approved my request for an expedited review and they should review it shortly.  As soon as they do it will be averrable for download.


Login or Signup to post a comment